Why do I see “Problem with the network” message?

The Rainbow app makes several requests to the connected cloud service accounts. Such a request could be to download a file or list the contents of a folder. Usually that request is successful, and we get the response that we anticipate from the service. But, in rare cases, we may see the “Problem with the network” message.

This is a very generic error message and it indicates that something went wrong. Most of the times, if we repeat that request after a few seconds it would be successful. But, if we keep getting that error, then we need to unlink that account.

Most of the cloud services that a user can manage with the Rainbow app uses the OAuth 2 protocol to authenticate a user. This means that when we add a new account we are directed to that service’s page and we enter our credentials. The Rainbow app can not access the information that we entered at that site. But, when we are logged in, the Rainbow app gets two tokens from the service: a refresh token and an access token.

The access token is used to all requests that the Rainbow app makes to a service. Because the access token has an expiration date, the refresh token is used to refresh it. But, if we have not accessed an account for a long period of time (close to a month), the refresh token can also expire. If this happens, we will see the “Problem with the network” message. That message will persists no matter how many times we try that request. The only way to fix this problem is to unlink that account, and add it again.

  •  
  •  
  •  
  •  
  •  
  •  
  •  

2 comments for “Why do I see “Problem with the network” message?

  1. March 18, 2020 at 12:07 pm

    Hi there just wanted to give you a quick heads up and let you
    know a few of the pictures aren’t loading correctly.
    I’m not sure why but I think its a linking issue.

    I’ve tried it in two different browsers and both show the
    same results.

  2. March 19, 2020 at 3:18 pm

    Hello,

    Thank you for the information. Do you have this problem with this site or with the app? If it is with this site, could you tell us which page(s) has this issue?

    Thank you

Leave a Reply

Your email address will not be published. Required fields are marked *